You can expect some error messages during a Mac installation of MedImage Server, which is correct behaviour in the following circumstances:

  • ‘xcode-select: error: command line tools are already installed’. You may want to upgrade, but the chances are that you won’t have to.
  • ‘Error: node x.y.z is already installed’. You may want to upgrade, but the chances are that you won’t have to.
  • ‘[PM2][ERROR] Process medimage-server not found’ provided it is followed by ‘Status’ ‘Online’ in green.
  • ‘Failed to acquire exclusive access to AutoFill corrections SQLite ..’. ┬áThese are Safari messages, but are not important for MedImage Server

This is a successful installation below: